Guest WiFi connectivity troubles

Incident Report for FCDC Services

Resolved

The guest Wifi has remained stable since the implementation of the fix, thank you for your patience.
Posted May 21, 2026 - 15:57 EDT

Monitoring

A fix has been implemented and we're continuing to monitor. Thank you.
Posted May 21, 2026 - 13:35 EDT

Investigating

We're aware of an issue with connecting to the Guest WiFi in the downtown campus. Updates will be provided as they're available.
Posted May 21, 2026 - 09:32 EDT
This incident affected: Network Infrastructure (Public Wi-Fi).