After some additional testing, the sites are now responsive. Granicus has not acknowledge the outage, so it may be outside their infrastructure. In any case, for now the sites are working on the internal network and 3 different 5G providers (Verizon, AT&T, T-Mobile). Odds are everything is back to normal. We will be actively monitoring for the next hour or so to confirm.
Posted Sep 14, 2026 - 12:50 EDT
Investigating
The primary Franklin County website -- franklincountyohio.gov -- appears to be down from the internal county network and from select Internet carriers. We have checked for a notice at status.granicus.com but so far they are not reporting an outage. We are troubleshooting now.
Until this is resolved, all websites hosted by Granicus may be down for most, if not all, users internally and publicly.
Posted Sep 14, 2026 - 12:41 EDT
This incident affects: County Shared Services (Public Service Websites).