Webex Calling Service Degradation

Incident Report for FCDC Services

Resolved

Cisco resolved all remaining issues overnight and the system is now fully operational.
Posted Jun 04, 2026 - 08:26 EDT

Update

Cisco is reported most, but not all services are restored. Voicemail and Contact Center may still be affected. FCDC continues to monitor progress.
Posted Jun 03, 2026 - 16:16 EDT

Monitoring

Data Center continues to monitor the incident. Cisco reports that some Webex services have recovered and are stabilizing, while others continue to experience degraded performance.
Posted Jun 03, 2026 - 13:07 EDT

Identified

Cisco is troubleshooting an issue affecting Webex Calling in North America. Users may experience issues signing in/out until resolved.
Posted Jun 03, 2026 - 09:27 EDT
This incident affected: Phone Services (Webex Calling).