Email Service disruption

Incident Report for FCDC Services

Resolved

Microsoft had identified the cause and implemented a fix. Our backlog has caught up and new emails are not being delayed.
Posted Sep 04, 2026 - 11:26 EDT

Update

Microsoft is still working on resolving the issue fully, and they have formally posted about the problem (incident EX1467029). Our mail backlog is still catching up, and it may take a couple more hours to fully resolve.
Posted Sep 04, 2026 - 09:59 EDT

Monitoring

Email relay flow is returning to normal and the backlog of email messages is being delivered. It may take until approximately 10:00 a.m. Eastern for all backlogged messages to be delivered. (Microsoft confirmed the problem and made adjustments to their services.) We will close out this incident once all the backlogged email has cleared.
Posted Sep 04, 2026 - 08:48 EDT

Identified

* Email send TO our accounts from sources outside our environment are flowing normally.
* Email sent FROM regular user accounts is flowing normally.
* Email from on-premises sources (like FCJS reports, secure email transfers, scan-to-email, etc.) are impaired due to delays in receiving the messages from our relay servers; this started around 6:00 a.m. Eastern today.
* We have opened a support session with Microsoft and are working toward a resolution.
Posted Sep 04, 2026 - 08:00 EDT

Investigating

We’re seeing service issues that’s causing delays in receiving emails.
Posted Sep 04, 2026 - 06:43 EDT
This incident affected: Third-Party Hosted Services (Microsoft 365).